ToscanaJ User Manual
About this Manual
This manual is work in progress. The first aim is to give a structured overview
of the features found in ToscanaJ, once that is complete, the different parts will
be elaborated into proper descriptions. At the moment OpenOffice is the tool of
choice, the document will thus be available in Writer's1 format and in PDF. A
license has not yet been chosen, but you can ask me (peter@peterbecker.de) if
you want a copy – the final license will an open source one, derivates for
particular scenarios will be allowed.
The manual is aimed at people without any prior understanding of the
technologies particular to ToscanaJ (Formal Concept Analysis, Conceptual
Information Systems), but with basic computer skills such as using the mouse
to navigate through menus.

Introduction
ToscanaJ is a browsing frontend for Conceptual Information Systems (CIS) in
the tradition of the Windows-based Toscana tools.
What does this mean?
1. First of all we are talking about an information system – a system that is
able to store and present information to a user. We are also talking about
conceptual systems – systems based on the notion of a “concept”. While
“concept” seems to be an obvious notion to humans, most data-analysis
software does not have this notion at all – these systems use numbers for
everything. Conceptual Information Systems try to achieve a better
understanding by analysing data using the notion of “concepts”.
2. ToscanaJ is a browsing frontend, which means you cannot edit anything in it.
The ToscanaJ suite comes with editors for different types of CIS (with or
without relational database in the backend), but editing can be a complex
task and this complexity is not exposed to the user of the final system.
There is no way to change the conceptual information system by using
ToscanaJ, which means its users cannot break anything. This does not mean
the program authors think the users are stupid, it just means they believe in
safety belts.
3. ToscanaJ is built on more than 10 years of experience with Conceptual
Information Systems, mostly in the form of a Windows-program called
“Toscana”. The authors of ToscanaJ try to continue the tradition of Toscana
by creating practical tools based on solid mathematical theory but made in a
way that no mathematical understanding is required.
The core notion in a ToscanaJ system is the notion of a line diagram. These line
diagrams are a particular type of diagram, called Hasse diagrams. They will be
introduced after a little excursion into the philosophical background of
“concepts” and before discussing the broad set of features ToscanaJ offers
around them.
1 OpenOffice's word processor

What are “Concepts”?
A line diagram in ToscanaJ represents a mathematical structure called a
concept lattice. Concept lattices are structures on concepts which are
expressed as intent (the distinguishing features of the concept) and extent (the
individuals which instantiate the concept). We call the features in the intent
attributes and the individuals used the objects. A concept like “actor” might
have attributes like “is human” and “plays a role” and you will find many
celebrities in the extent.
Concepts have to be understood in a certain context – while the “actor”
example above might seem reasonable, there are questions you can ask, such
as: “what happens if the movie is computer-generated?”. In this case the
context changes and the “actor” concept we introduced is no longer valid since
there are now actors that do not match the “is human” attribute. This is a
general problem with concepts that they need a context to be well-defined and
human history gives many examples where misunderstandings occurred since
concepts where seen in different contexts.
A concept lattice is a set of concepts with an order on them. The order defines
a hierarchy on the concepts, you have subconcepts and superconcepts. In a
lattice about transportation you might find that a concept of vehicles is a
superconcept of busses (superconcept = more general) while the busses are a
subconcept of vehicles (subconcept = more specific).
These notions are modelled mathematically and the structures are calculated
by the ToscanaJ software, but you will not need to understand how this works.
To use ToscanaJ the abstract (and hopefully intuitive) view given here is more
than sufficient.

The ToscanaJ User Interface
Let us look at the main aspects of ToscanaJ's user interface. Figure 1 shows a
screenshot of ToscanaJ where the most important parts of the main window
are labeled.
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Figure 1 A screenshot of ToscanaJ

The main part is the diagram view. In the diagram view a line diagram is

displayed, along with a number of labels showing information about the data.
The diagram preview shows the same diagrams, but with reduced labeling.
How to read these diagrams will be explained in the next section.
The diagrams are selected by their title from the list of available diagrams in
the upper left corner. This list contains all diagrams defined in the conceptual
information system currently opened. The list below is the list of selected
diagrams. Here all the diagrams used in a particular analysis session are
shown. You can select diagrams from the list of available diagrams by doubleclicking their title or by selecting them and then clicking the ADD SELECTED button.
This adds the diagram to the end of the list of selected diagrams. To remove
the last diagram from the list of the selected diagrams, click the REMOVE LAST
button. The order of the selected diagrams can be changed by dragging the
names in the list.
If no diagram was shown before, the first selected diagram will be shown in the
diagram view. The preview will always show any diagram you click upon in
either of the two lists.
The examples we use in this manual all come out of the PC-Test example that
is provided in the standard distribution of ToscanaJ. It contains data from a
review of PCs with a 80486 processor – this is a rather old example even
before the Pentium days, but since we are not interested in the data itself it
does not matter. A review of some products is a good example where a
Conceptual Information System can be used, although there are many others.
Normally you should be able to find the corresponding ToscanaJ system in the
folder examples/sql/pctest in your ToscanaJ installation. To load it, press the
OPEN... button or select File->Open... in the menu, then navigate to the folder and
select the pctest.csx file to open. As a result you should get a list of diagram
names appearing in the upper left corner of the screen.

Reading Line Diagrams
The example diagram we are going to look at first is the “Cases” diagram. To
open it, double-click on its name in the list of available diagrams. The result on
screen should look similar to Figure 1.
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Figure 2 The diagram "Cases" and its parts

Figure 2 shows the same diagram by itself with its parts labeled. The nodes
represent the concepts of the lattice, the order on the concepts is shown by the
edges. Each node at the top of an edge represents a concept more general
than the one below. In the example diagram the two concepts labeled “Tower”
and “Desktop” are more general than the concepts below. Mini-towers are a
subtype of towers and small-footprint and slimline cases are considered
subtypes of desktop cases.
There is always a top and a bottom node. The top represents the concept of
every object available. The bottom represents the concept of everything being
true: any object attached to it has all attributes in the diagram. In many cases
the bottom is empty, as in the example diagram – there are no cases that are
towers and desktops at once.
The labels show the attributes and the numbers of objects particular to the
concepts. The leftmost node represents a concept with 4 objects, as the
number in its object label shows. The intent of the concept are the attributes
“Mini-Tower” and “Tower”. Note that the intent is not just the label attached to
the node, but also all labels of nodes connected by upward pointing edges.
Since all mini-towers are towers, this information is not repeated.
Similarly the objects are not displayed multiple times. The number 22 at the
concept labeled “Tower” represents the 22 PCs whose cases are towers, but
not mini-towers. Together with the 4 mini-towers there are 26 PCs with tower
cases. The number of PCs with any type of desktop case is 25 + 14 + 8 = 47
PCs.
The number of all objects matching a concept – its extent size – is visualized in
the color of the nodes. The darker a node the more objects match a concept.
The node for desktop PCs is much darker than the node for tower PCs, since
there are 47 desktop PCs but only 26 tower PCs.
There are two features in ToscanaJ that can help you reading the diagrams.
The first one is a dialog you can open using View->Show Concept Information.

If you have this dialog open and point the mouse pointer on a node in the
diagram, ToscanaJ will display the intent and the extent of the concept. Figure
3 shows this dialog containing the information for the central node in the
example diagram. All attributes above have been collected and the objects
below – in this case there are only the objects of the node itself. If the number
of objects is below a certain threshold, a list will be displayed instead.

Figure 3 A dialog showing intent and extent

The same information can be copied into the clipboard of the operating system,
so it can be copied into another program. This can be done by opening the
context menu on a node and selecting the Export Concept Information option.
Such a copy looks like this:
Intent (2 attributes):
+ Small-footprint
- Desktop
Extent (14 objects):
+ Arche Legacy 486/66DX2
+ ATronics ATI-486-66
+ Clover 486 Quick-I Series
+ Dell 466DE/2
+ EPS ISA 486 DX2/66
+ GCH EasyData 486DX-2/66
+ Hyundai 466D2
+ IDS 466i2
+ Memorex Telex 8092-66
+ NCR System 3350
+ Osicom i466 MOD 420
+ QSI Klonimus 486DX2/66
+ Quill Qtech 486 4D2/66
+ Twinhead Superset 600/462D
The full intent and extent of the concept selected are shown, the attributes and
objects particular to a concept are marked with a plus symbol, the ones
marked with a dash are accumulated from sub- or superconcepts.
Another feature that helps reading diagrams is highlighting. By single-clicking

on a node the node and all relevant parts of the diagram are highlighted. This
is shown in Figure 4, where the “Small-footprint” node is highlighted.

Figure 4 Highlighting a node in a diagram

You can select another node to change the highlighting or you can single-click
on the background of the diagram to remove the highlighting.

Changing Label Contents
The section before described the diagram with default settings. You can change
many aspects of what is displayed using the view menu or context menus2 on
the object labels.
The first option is to let ToscanaJ show the extents on the nodes. Instead of
just displaying the exact matches like the 22 PCs which have tower cases, but
not mini-towers, ToscanaJ can display all 26 PCs with any type of tower case,
including the mini-towers. This can be changed using the first two entries in
the View menu.
You can also display more than just the number of objects. The options of what
the object labels can contain depend on the data used. The setup for these
options is stored in the schema file ToscanaJ opens. The PC-Test example has
many different options, but before we discuss these let us look at the three
default options most systems will offer:
Count: is the option discussed so far. It shows you how many objects belong
to a particulat concept – either as exact matches or as part of the extent;

2 Invoked by right-clicking on a label on most operating systems

Figure 6Label without scrollbar

Figure 5Control
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List: enlists all the objects for a particular concept. These lists can take up a
lot of space, but they can be resized and the contents can be scrolled. Figure 5
shows the label elements which are used to do this. These control elements are
shown only if the mouse pointer is on the label, otherwise a label as seen in
Figure 6 is used;
Distribution: is similar to the count option, but instead of displaying the
absolute numbers, the percentage of all objects is displayed -- Figure 7
illustrates this option.

Figure 7 Distribution of objects

To change the content of all object labels, you can chose one of the options in
the View menu or alternatively use the context menu of the diagram
background. But you can also change the option for only one label. This is
often helpful to see a list of objects for a particular concept. Instead of
changing all labels you can use the context menu of the corresponding object
label where you find the option “Change label”. A selection in its sub-menu will
affect only the label you clicked upon.
The system you use might have additional label contents configured. The PCTest example has six further options to demonstrate the functionality. The rest
of this section describes these extra options, if you use a system without extra

options you might want to skip forward to the next section.
Extra options in ToscanaJ systems are configured as database queries. There
are three basic types of queries ToscanaJ can do: lists of objects, aggregates
and lists of partitions. All of these options allow combining multiple columns of
a database and the formatting of the entries.
Object lists correspond to the normal list option, but a system might query
other or just more information instead of the object's name. Aggregates can be
just a count as the other default options or they can be sums of values, or
averages or similar information. Aggregates can be shown either as absolute
values or relative to the same aggregate on all objects. The latter can for
example be used to show the average price of the PCs in a concept compared
to the average price of all PCs. The lists of partitions allow showing features
independent of the attributes in the object labels. The number of entries in
such a label can be smaller than the number of objects since some objects
might share a feature.
The six extra options in the PC-Test example illustrate these options:
Cases: this shows a partitioning of the PCs in a concept according to their case
type. In the “Cases” diagram this will result in each label containing the
attributes for the concept, but in other diagrams this label content can be used
to quickly see which case types are available within a particular object set;
Name with type of case: this shows a list combining extra information into
the label. Beside the name of the PC normally shown, its case type will be
displayed;
Average Price: this label content calculates the average of the price for the
PCs;
Average Price (relative): this is the same query as before, but this time the
result is also compared to the average of all PCs in the diagram and displayed
as percentage of this. A value of 80% would mean that the average price of
the PCs in the label is only 80% of the total average;
Min/Max Prices: this uses two aggregates at once to show the price range in
a certain concept;
Count (relative): this query combines the two standard queries for the
counts – both the absolute count and the percentage of the whole object set is
shown at once.

Getting Information on Diagrams
Some conceptual information systems may give additional information on the
system as a whole, on diagrams or on particular attributes. The following
features are available only if such help has been configured in the opened
system.
About Schema: the ABOUT SCHEMA... button appears if the schema has a
description attached to it. Clicking on this button will typically open a
description of the underlying data and/or an overview of the available
diagrams. An entry in the Help menu offers the same function.
About Diagram: the ABOUT DIAGRAM... button is available if some diagram in the

schema has a description attached to it and it can be used whenever the
currently visible diagram has a description3. Typically this will give some
information about the intention of the diagram and how it should be read. An
entry in the Help menu offers the same function.
Attribute Descriptions: some systems might have extra information attached
to the attributes in some diagrams. To access this, open the context menu on
an attribute label. If the system has a description of the attribute in it or if
extra views on the attributes are available, you can pick these from the menu.

Additional Object Views
Often additional information on the objects is too large to fit into the labels.
ToscanaJ allows conceptual information systems to have extra views attached
which show more information on one object or a set of objects. These extra
views are accessible through the context menu of the object labels.
There are two basic types of these views: those which show information about
a single object and those who summarize a number of objects. The former are
called “forms”, the latter “reports”. These presentations are similar to the ones
used in standard database frontends.
Forms can be accessed only from object lists containing single items. When
opening a context menu for an object, for example from the default “List” label
content, you can pick all forms available using the View Selected... menu entry.
This will show you more information on a single item. One example from the
PC-Test system is shown in Figure 8 – it shows a common type of form,
presenting some information about an object in a table. It can be accessed as
HTML View....

Figure 8HTML View of a selected
object

A report can be done using tables, too. Reports can contain tables with
information about each object in the selected set, as well as aggregates like
sums, averages or counts. Figure 9 shows such a report, again from the PCTest example system. Reports for the whole object sets are accessible through
the context menu of all label types, using the View all Objects... entry.

3 In the case of a nested diagram (see below), a menu will be opened to chose if the
description of the inner or outer diagram should be opened

Figure 9Report for all objects

Another – less common – way to use reports is on labels which show a
partitioning. In the PC-Test example this can be used with the “Cases” label
entry type. If this type is used, the View Selected... entry will show a report only
on the objects of the case type selected.

Filtering Objects
Analysing the whole object set as we did it up to now is quite helpful, but
sometimes one wants to focus on a particular object set. For this purpose
ToscanaJ offer the option to filter objects. When filtering, the object set behind
the diagrams gets reduced to a selected subset of all objects.
To reduce the set of objects used in the diagrams, you have to select a second
diagram first. By double-clicking a diagram title in the list of available
diagrams, you can add as many diagrams to the list of selected diagrams as
you want. These will be visited in the order you chose.
As long as another diagram is available in the list of selected diagrams, you
can select a concept in the current diagram to be used for filtering by doubleclicking on the node. In the default settings this reduces the objects used to
the extent of this concept, that is all objects in its label and the labels below.
ToscanaJ will then present you the next diagram using the reduced object set.
The list of selected diagrams uses different fonts for the diagram titles to
indicate which diagrams have been visited, which diagrams are currently visible
and which ones are to come. The fonts used are a normal font for visited
diagrams, a bold font for the current diagrams and an italic font for the ones to
come. Figure 10 shows the different sections in the list of selected diagrams.

Figure 10Selected Scales
View

While ToscanaJ will chose the objects in the extent of the selected concept by
default, this can be changed from the Diagram menu. This menu contains the
entries Filter: use all matches and Filter: use only exact matches. Using these entries
you can change the filtering to use only objects with a certain attribute set (but
not more) or the objects matching the attributes of the selected concept and
maybe more. This can be changed in hindsight, the diagram will be updated
with the new filter option whenever the option is changed.
As long as a filter is still active, you can go back one diagram. This can be done
with the GO BACK ONE DIAGRAM button, or the corresponding menu entries in the
View menu and the context menu of the diagram background. This way the
results of different filters can be explored.
Another option to see the changes due to different filters is using the diagram
preview. If you select one diagram from the list of visited diagrams, the
concept selected for filtering will be highlighted. You can change the filter by
clicking on another concept in the diagram preview. This will update the
diagram shown in the main diagram view with the new filter option.
Which attributes have been used to filter the current diagram can be seen
using the ANALYSIS HISTORY... button. This will open up a window such as in Figure
11. In this window you can see which diagrams have been visited and which
attributes from these diagrams have been selected.

Figure 11Analysis history

The list of selected diagrams allows reordering the diagrams which are shown.
A diagram can be dragged up and down in the list, as long as no diagram is
involved that is used for filtering.

Nesting Line Diagrams
The process of filtering allows viewing diagrams in respect to certain subsets of
the objects. By going back and forth you can see how these changes affect the
distribution of objects in another diagram.
Sometimes it is helpful to see how one diagram is affected by filtering through
all concepts of another diagram. ToscanaJ allows nesting one diagram (the
inner diagram) into another diagram (the outer diagram). Figure 12 shows the
“Graphic card” diagram nested into the “Cases” diagram. Each of the inner
nodes of this diagram represents a combination of attributes from the outer
and the inner diagram. For example one can see that there are three PCs
which have an ISA Bus graphic card and a Mini-Tower case by looking at the
leftmost label in the diagram.

Figure 12Nested line diagram

To read this type of diagram you have to follow the inner and the outer edges.
Each node in an inner diagram is considered connected to the same node in
nodes above in the outer diagram. Highlighting can be used in the same way
as in the normal (flat) diagram. The result of clicking on the node just
described is shown in Figure 13.

Figure 13Nested line diagram - highlighted

Nesting is quite helpful to see how the attributes of one diagram affect the
occurance of attributes of another diagram. Often one can see missing
combinations, such as the combination of “Vesa Local Bus” graphic card with
“Slimline” or “Mini-Tower” cases.
When nesting all sizes of the diagrams get adjusted so the full nested diagram
fits onto the screen. Sometimes the labels can get quite small and hard to
read. To avoid this, you can set a minimum font size for the labels. This can be
done using the View->Set minimum label size option.

Printing Diagrams
You can print diagrams from ToscanaJ using the File->Print menu option. This
prints the current diagram using the standard means of printing on your
operating system. Typically a dialog will open where you can chose the printer,
the number of copies and possibly other options. ToscanaJ will print the
diagram on the selected printer while trying to stay to the view on the screen
as close as possible. The diagram will be scaled to fit exactly onto the page.
Printer settings are accessible through the File->Print Setup...menu option. Here
you can chose the orientation of the diagram (landscape or portrait), the
margins and the paper type and source. After the selection the normal printing
will be initiated.
Normally ToscanaJ will print in color. If your printer does not support color, the
color gradient used in the standard settings is not the best option for printing,
since it will not produce a full black to white gradient. Or sometimes you might
not want a gradient at all in printouts. For this the View->Color schema menu
gives the following options:

Default: this is the normal mode with the color gradient
Grayscale: the gradient used goes from black (top) to white (bottom)
White nodes: all nodes are white
Black nodes: all nodes are black
User Defined: this schema can be changed in the preferences
Changing this option will affect not only the printing, but also the on-screen
view and all diagram exports (see below).

Graphic Export
Diagrams can be exported into different graphic formats. This allows
integrating the diagrams in documents, presentations and websites or postprocessing them before printouts.
A diagram can be exported using the File->Export diagram... menu entry. This will
open a dialog as shown in Figure 14. In this dialog you can select where to
write the export file and which name it should have – this happens in the way
you save any file. To the right you find some extra options, specific to
ToscanaJ.

Figure 14Export graphics dialog

The first is choosing a size for the exported image. By default ToscanaJ will use
the same size as the diagram has on the screen. You can change this by
unticking the USE SCREEN SIZE checkbox and selecting a different size. The diagram
will be scaled to fit the new size, this will always keep the aspect ratio – the
result will never be stretched.
The second set of options allows you to export the analysis history with the
diagram. This is the same as you get with the ANALYSIS HISTORY... button described
above. Here you have two options: first you can copy the history into the
system clipboard, so you can paste them into a document. This can be helpful
if you want to import the diagram into a document directly after the export and
you want to use the history as a description. Alternatively or in addition you
can save the history to a file. In this case a second file will be saved, which has

the same name as the diagram plus a second extension “.txt”. If you save your
diagram as “diagram1.png”, the history will be saved in a file called
“diagram1.png.txt”.
You can also force a background color. Some formats such as PNG allow a
transparent background, but while this is often quite useful, it can also cause
problems in some tools that do not support transparency properly. In this case
you can use a fixed color instead.
The graphic format used for the export can be chosen in two ways. One way is
picking the format wanted from the FILES OF TYPE list at the bottom. In this case
the selected format will be used and the extension for the file can be
automatically be determined – if you do not provide an extension, ToscanaJ
will add the default extension of the graphic format for you.
If you select ALL FILES as the file type option, ToscanaJ will try to guess the
format wanted from the extension given. If you name the file with an extension
known to ToscanaJ, it will pick the corresponding format. If the extension is not
known, the export will be abridged. Unless you export into different formats
quite often, we recommend picking your format of choice once and leaving it at
this setting – ToscanaJ will remember your choice, even after a restart.
Diagrams exported will look very similar to the diagram on screen, in many
graphic formats no difference should be visible at all. Some formats will not
allow an exact match, but the results should be still very close. By default
ToscanaJ supports PNG and JPEG as export formats, other formats can be
added using plugins – extra program parts you can download from the Internet
separately.
Here is a list of the most important graphic formats supported by ToscanaJ and
where they are best used. The formats which require a plugin are marked with
a star.
PNG: PNG is a good format for web-publishing and for embedding in
documents and presentations. It is supported by many programs and is
reasonably small without compression loss. It also supports transparency,
which means the diagram will not have a visible background unless forced with
the extra option.
JPEG: JPEG is even more widely accepted by programs, but it is not optimized
for diagrams – its purpose are photorealistic pictures and it uses a compression
technique which can leave visible artifacts in diagrams. It does not support
transparency, typically ToscanaJ will export JPEGs with a white background.
PDF*: PDF is very good for printing purposes and good text publishing tools
will allow you to embed the diagrams into documents. It can also be used in
combination with the LaTeX typesetting software. The main advantage of PDF
over formats like PNG or JPEG is that they scale: you can resize the diagram
and it will still look good – the other formats will produce visible steps in the
lines and circles.
SVG*: SVG is a rather new format with similar functionality to PDF. It is
optimized for web-publishing and there are some tools that allow editing the
SVG format. If you have such a tool, you can add text to the diagram, move
shapes, change colors, add drop shadows or do whatever the program

supports with it. All lines and circles will be available as editable objects.
EPS*: EPS is in some way a predecessor of the PDF format. It has similar
functionality but produces typically slightly inferior results when exported from
ToscanaJ. We recommend using PDF or SVG if possible.
EMF*: EMF – often called WMF after its predecessor – is a format often used
on the Windows systems, most noticably Microsoft Office. If you want to
embed the diagrams into Microsoft Office documents and have difficulties with
other formats, this might be a good choice.

Advanced Features
The features described in this section are only for advanced users. If you are
new to ToscanaJ you should know enough to use it successfully. You might
want to skip this section and maybe read it after you have some experience.

Editing Preferences
By calling View->Preferences... you can change a number of settings in ToscanaJ.
These are distributed in a number of sections, accessible through tabs. These
sections are:
Diagram colors: here most colors used in the diagrams can be changed. Note
that the empty nodes and the background normally do not have a color set, in
the former case this means that the empty nodes have the same color as the
normal ones, setting a color will result in all empty nodes having this color. In
the case of the background it means that the background is transparent –
setting a color for it will cause not only the on-screen view to use this, but also
printouts and diagram exports. At the moment the colors can be unset only be
restoring the full default settings, see below how this can be done.
Diagram options: here you can set the default label font, the gradient type
and node scaling options (see below) and some sizes for diagram drawing. The
default values for the latter are 20 pixels margin on each side of the diagram,
a node for a non-realized concept (i.e. an empty node) is reduced to a third
(i.e. divided by 3), a highlighted line is 3 times as wide as a normal line and all
not-selected parts in a highlighted diagram are 70% transparent.
Line Labels: ToscanaJ can display labels on the lines, showing the ratio of the
extents of the upper and lower concept. This can be turned on here, together
we two related options: one to change the width of the lines according to this
ratio, another groups nodes representing the same extent with one of two
visual clues (note that this is always one realized concept plus a set of
superconcepts which are not realized). The labels will have a number in them,
using the format given or the default, which is “0.00%” -- formats are given
similar to spreadsheet applications, if the format ends on a percent symbol, it
will be a percentage, otherwise a normal float value. The font size can be
adjusted and the two colors used can be set: the labels use a flood effect,
similar to a bar chart. You can set both colors to the same to avoid this effect.
Extra Features: here you can turn on extra options in the view menu (see
below), you can turn off the diagram preview in the lower left corner (to save
screen space) and you can turn on the display of the internal coordinates of the

nodes. The latter is meant only for debug purposes and curios people.
In case ToscanaJ got misconfigured, it can be reset by calling it from the
command line with the “-reset” option. This way all default values will be used.
Note that it also resets the session management, which means ToscanaJ will
forget all window positions, directories used in dialogs and similar information.

Changing the Gradient
Typically ToscanaJ displays a node color calculated from the extent size of the
underlying concept. The colors for this gradient can be chosen in the
preferences.
You can also change the type of the gradient so ToscanaJ uses the contingent
sizes instead – this means the number of objects matching a concept's intent
exactly, as in the default labels. This can be done either directly from the
preferences (in the diagram options section), or the View menu can be extended
to include menu options for this (via the extra features section of the
preferences).

Using Node Scaling
The same information used in the gradient – number of objects matching the
attributes in either of the two ways – can be visualized in a second way: as the
size of the nodes. Similarly to the gradient options this can be either chosen
directly in the preferences or the options for the View menu can be turned on
there.

Orthogonality Analysis
A last option for the View menu, which can be turned on in the preferences, is
the orthogonality analysis. This is useful for nested diagrams, when you want
to know in more detail how the attributes of the outer diagram affect the
probabilities of the attribute in the inner diagram. While the not-realized
concepts indicate full implications, often any deviation from independence can
be interesting. To show this you can use the orthogonality analysis feature in
ToscanaJ, which applies a Pearson's Chi square test to each combination of
outer and inner intent.
The idea behind this test is that if there would be independence, the relative
frequency of any intent in the inner diagram in any outer node should be equal
to the relative frequency in the non-nested diagram. The deviation from this
hypothesis can be tested statistically and ToscanaJ displays the statistical
significance of the deviations as color: red for negative deviation (less than one
would expect), green for positive deviation (more than one would expect). The
more intense the color, the more significant the deviation, that means the less
likely it is that this could occur randomly. To see the significance levels, you
can add a legend to the diagram via the View menu.

